Fullscreen mode in games

General discussion of show topics and feedback.

Moderators: snarkout, Patrick, dann

Post Reply
User avatar
CptnObvious999
Posts: 798
Joined: Fri Jun 03, 2005 7:54 pm
Location: Maryland
Contact:

Fullscreen mode in games

Post by CptnObvious999 » Tue Aug 01, 2006 9:21 pm

When I open a game such as Quake 4 or Sauerbraten or anything else that can go fullscreen, it only uses the middle of the screen and is the size that I set the game resolution to. For me I have my screen resolution at 1600x1200 but I can only run Quake 4 at 800x600 but instead of making the 800x600 use the entire screen it puts it in the middle so I have a lot of black space around it.

Does anyone else have this problem or know a solution or at least the reason it does this? I wonder if Xorg 7.1 fixes this...

Tsuroerusu
Posts: 2551
Joined: Mon Sep 05, 2005 8:51 am
Location: Silkeborg, Denmark
Contact:

Post by Tsuroerusu » Tue Aug 01, 2006 9:36 pm

And you ask why I stick to what a distro marked as "stable" gives me in most cases! :P :lol:
Image
Image

"Hatred does not cease by hatred, but only by love. This is the eternal rule."
- Siddhattha Gotama (Buddha), founder of Buddhism.

User avatar
dann
Site Admin
Posts: 1132
Joined: Mon Apr 26, 2004 10:55 pm
Location: Hampton, Va, USA
Contact:

Re: Fullscreen mode in games

Post by dann » Wed Aug 02, 2006 1:52 pm

CptnObvious999 wrote: For me I have my screen resolution at 1600x1200 but I can only run Quake 4 at 800x600 but instead of making the 800x600 use the entire screen it puts it in the middle so I have a lot of black space around it.

Does anyone else have this problem or know a solution or at least the reason it does this? I wonder if Xorg 7.1 fixes this...
I think the problem may be in your xort.conf file. Do you have screen modes defined for 800x600, 1024x768, and 1280x1024? If not, this may be what is causing the black border.

After you make those changes you will have to restart X I think for them to take effect.

User avatar
CptnObvious999
Posts: 798
Joined: Fri Jun 03, 2005 7:54 pm
Location: Maryland
Contact:

Re: Fullscreen mode in games

Post by CptnObvious999 » Wed Aug 02, 2006 6:51 pm

dann wrote:
CptnObvious999 wrote: For me I have my screen resolution at 1600x1200 but I can only run Quake 4 at 800x600 but instead of making the 800x600 use the entire screen it puts it in the middle so I have a lot of black space around it.

Does anyone else have this problem or know a solution or at least the reason it does this? I wonder if Xorg 7.1 fixes this...
I think the problem may be in your xort.conf file. Do you have screen modes defined for 800x600, 1024x768, and 1280x1024? If not, this may be what is causing the black border.

After you make those changes you will have to restart X I think for them to take effect.
Thanks Dann, you were right. A quick run of mkxf86config.sh and some tweaking and now I can see my games in true fullscreen in all its glory! (I still don't know exactly what was the option that made it do that but oh well).

Post Reply